nixvim/config/core.nix

67 lines
1.5 KiB
Nix

{
config = {
# Color scheme.
colorschemes.catppuccin = {
enable = true;
settings = {
flavour = "mocha";
no_bold = false;
no_italic = false;
no_underline = false;
integrations = {
cmp = true;
neotree = true;
harpoon = true;
gitsigns = true;
which_key = true;
illuminate.enabled = true;
treesitter = true;
treesitter_context = true;
telescope.enabled = true;
indent_blankline.enabled = true;
native_lsp = {
enabled = true;
inlay_hints = {
background = true;
};
underlines = {
errors = ["underline"];
hints = ["underline"];
information = ["underline"];
warnings = ["underline"];
};
};
};
};
};
# Options.
opts = {
# Indent settings.
tabstop = 2;
shiftwidth = 2;
expandtab = true;
# Line number.
number = true;
relativenumber = true;
signcolumn = "yes";
# Search case sensitivity.
ic = true;
# For dragging windows
mouse = "a";
};
# Clipboard.
clipboard = {
register = "unnamedplus";
providers.xclip.enable = true;
};
autoCmd = [
{
event = "InsertLeave";
pattern = "*";
command = "silent! update";
}
];
};
}