am-kernels/default.nix
xinyangli 8630fe7667
All checks were successful
Build nix packages / build-matrix (am-kernels) (push) Successful in 2m26s
Build nix packages / build-matrix (rv32Cross.am-kernels-nemu) (push) Successful in 2m23s
Build nix packages / build-matrix (rv32Cross.am-kernels-npc) (push) Successful in 2m21s
refactor: use cmake macros to do objcopy, install and tests
2024-08-15 17:52:04 +08:00

37 lines
586 B
Nix

{ lib,
stdenv,
cmake,
abstract-machine,
arch ? "riscv-nemu"
}:
stdenv.mkDerivation rec {
pname = "am-kernel";
version = "2024-07-10";
src = ./.;
nativeBuildInputs = [
cmake
];
buildInputs = [
abstract-machine
];
cmakeFlags = [
(lib.cmakeFeature "ARCH" arch)
];
cmakeBuildType = "Debug";
dontStrip = true;
doCheck = true;
meta = with lib; {
description = "AbstractMachine kernels";
homepage = "https://github.com/NJU-ProjectN/am-kernels.git";
license = with licenses; [ ];
maintainers = with maintainers; [ ];
};
}